Modulschachtvirus?

Bild Alles rund um Atari 8bit
Bild All around Atari 8bit

Moderatoren: Sven, Sleepy, Wolfgang, cas, des-or-mad

Modulschachtvirus?

Beitragvon Mathy » Fr 5. Apr 2019, 01:16

Hallo Leute

Da meine MIDI-Maze Module auf Treffen schon mal Probleme machen, wollte ich testen ob's an einem meiner XEs liegen könnte, oder ob alle meiner XEs Probleme mit diesem Modulen haben. Dabei habe Ich leider feststellen müssen, dass die Module bei mehreren Rechnern Probleme haben. Bei XE(GS)s mehr als bei XLs wie es scheint. Oft wird das Modul nicht erkannt. Wenn's nicht erkannt wird, hilft es oft, das Modul etwas nach vorne oder hinten btw. ob oder unten zu drücken. Wenn's erkannt wird, sorgt ein leichtes Drücken in irgend einer dieser Richtungen schon für Graphikfehler. Als Gegenprobe habe ich mein Ultimate Cart und mein BugHunt Modul ausprobiert. Dabei musste Ich feststellen, auch dort gibt es ähnliche Probleme. Und irgendwo in einer sehr dunklen, sehr staubigen Ecke meines Siebs (das ab und zu wie ein Bio-Speicher funktioniert) meine Ich die Erinnerung gefunden zu haben, dass Ich auf irgend ein Treffen im letzten Jahr auch schon Probleme hatte mit meinen 4MB Flashmodulen.

Was könnte obenstehendes verursachen und wie löse ich es?

Tschüß

Mathy
Benutzeravatar
Mathy
Night&Day Poster
Night&Day Poster
 
Beiträge: 4098
Registriert: Do 1. Jan 1970, 01:00
Wohnort: Heerlen, NL

Re: Modulschachtvirus?

Beitragvon Sleepy » Fr 5. Apr 2019, 07:40

Oxidierte Kontakte im Modulschacht? Kalte Lötstelle am Modulschacht?

BTW: Mein Pitfall-Cart für das VCS funktioniert nur wenn man es NICHT ganz in den Modulschacht steckt... mann mus es erst ganz reinstecken und dann einen Hauch wieder herausziehen. :mrgreen:

Sleepy
Benutzeravatar
Sleepy
Night&Day Poster
Night&Day Poster
 
Beiträge: 6779
Registriert: Do 1. Jan 1970, 01:00
Wohnort: Köln

Re: Modulschachtvirus?

Beitragvon CharlieChaplin » Fr 5. Apr 2019, 21:31

Nun,

1) bei selbst-gemachten Modulen (Midi Maze ist kein ROM, sondern ein Prototyp, vermutlich geliefert auf Eprom von Video61 oder Dropcheck oder sonstwem) gibt es hin- und wieder Timingprobleme, denn XL und XE haben ein voneinander "etwas" abweichendes Timing. Das Problem hatte ich schon in den 90ern, als mir Nir Dary einige seiner selbstgemachten Module schickte, die er alle auf XE-Rechnern getestet hatte, die aber auf meinen XL`s nicht laufen wollten...

2) auch bei kommerz. ROMs gibt es hier und da Kontaktprobleme, die Modulschächte meiner XL's sind allesamt in Ordnung, trotzdem muss ich insbesondere die XE-Taiwan Module (geriffelt an der Seite, Fuji-Logo auf der Rückseite, etc.) mehrmals in den Modulschacht stecken, bis sie dann laufen; während die XE Hong Kong Module (Schraube unter dem Label, Nase oder Wegwerfgriff auf der Rückseite, etc.) allesamt auf Anhieb im XL Modulschacht funkt.; hält man die Platinen so, dass man die Kontakte sehen kann, sieht man mit bloßem Auge, dass die Kontakte bei den XE Hong Kong Modulen ein wenig länger bzw. bei den XE Taiwan Modulen ein wenig kürzer sind (das lässt sich auch nachmessen);

Da ich nur XL's besitze habe ich versucht mir von allen XE Modulen die Hong Kong Variante zu besorgen, jedoch scheint es einige Module (z.B. Archon) nur als Taiwan Variante zu geben oder sie sind als Hong Kong Version schwer zu finden... bei meinem Midi Maze Modul von Video61 handelt es sich um eine Taiwan Variante (mit kurzen Kontaktpins), wenn ich mich nicht irre, gibt es von Dropcheck auch nur die Taiwan Variante (bzw. nur die Platine mit den kurzen Kontaktpins, die der Taiwan Variante entspricht)... die Ultimate Cart habe ich vom Entwickler als Platinenversion 1 für Taiwan Modulgehäuse bekommen, von santosp gab es bzw. bekam ich dann später eine leicht geänderte Platine, die jedoch ebenfalls für ein Taiwan Modulgehäuse gedacht ist...

3) ansonsten gibt es nur die allg. Ratschläge: a) Modulschacht säubern, b) Modul (Kontakte) reinigen, c) bei selbstgemachten Modulen die Platine am äußersten Ende ein klein wenig mit der Feile bearbeiten, so wie es mal in einem Abbuc Magazin beschrieben wurde (das Platinenende sieht dann ein wenig abgeschrägt / \ aus und es wird so verhindert, dass dauerhaft der Modulschacht beschädigt wird; Atari hat das bei den eigenen, kommerz. verkauften Modulen wohl auch so gemacht)...
CharlieChaplin
Night&Day Poster
Night&Day Poster
 
Beiträge: 2140
Registriert: Do 1. Jan 1970, 01:00


Zurück zu Hardware



Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste