ULTIMATE CARD defekt?

Bild Alles rund um Atari 8bit
Bild All around Atari 8bit

Moderatoren: skriegel, Wolfgang, cas, Sleepy, des-or-mad

ULTIMATE CARD defekt?

Beitragvon Atausla » Mo 29. Jun 2020, 20:12

Hallo,

ich habe vor Kurzem eine ULTIMATE CARD bei Ebay erworben.
(von ALPHA LABS aus Italien)
Nun habe ich festgestellt, das nicht alle Directory-Einträge vom ATARI
gelesen werden können.
Die Ordner erscheinen leer, obwohl xex, atr`s usw gespeichert sind.
Habe auch schon eine andere SD-Karte probiert, aber das Problem besteht
weiterhin. Was kann ich nun machen?!? Behebt eine neue Firmware das
Problem? Hat jemand ähnliche Erfahrungen gemacht ?!?

:roll:

Andreas
Atausla
Newbie
Newbie
 
Beiträge: 47
Registriert: Fr 2. Okt 2015, 19:28

Re: ULTIMATE CARD defekt?

Beitragvon CharlieChaplin » Di 30. Jun 2020, 00:37

Ähem,

es gibt für die Ultimate Cart. schon länger keine neue Firmware mehr. Genauer gesagt gibt es auch nur zwei Firmwares, nämlich die allererste und tada, genau ein Firmware-Update. Danach ist nie wieder etwas erschienen. Die allererste Firmware konnte nur CAR/ROM laden, mit dem Update kann man auch XEX laden, ATR's können mit der Ultimate Cart. gar nicht geladen werden. Wenn du also XEX Dateien laden kannst, dann hast du schon die neueste / letzte / aktuellste Firmware... (sichtbar auch an der Versionsnummer 1.1 oben rechts im Menü).

Wie bei allen Flash-Carts. ist es auch bei der Ultimate so, dass nicht jede x-beliebige SD-Card damit geht, hier muss man ggf. ausprobieren, bis man eine SD-Karte findet, die damit funktioniert. Ich habe bisher mit Sandisk recht gute Erfahrungen gemacht, natürlich gibt es aber auch da Karten die zickig sind. Auf meinen alten 2GB Sandisk Karten für die Ultimate Cart sind alle Programme in Ordnern und Unterordnern drin (z.B. CAR > ACAR, BCAR, etc. oder XEX > AXEX, BXEX, etc.) und lassen sich problemlos laden. Benutzt du bei den Ordnern oder Dateinamen vielleicht Leerzeichen (white spaces) ? Falls ja, könnte das ein Problem sein - zum Austesten einfach mal 1-2 Dateien oder Ordner mit Leerzeichen umbenennen und die Leerzeichen gegen Unterstriche austauschen. Wenn das was bringt, musst du wohl alle Leerzeichen durch Unterstriche ersetzen; wenn es nix bringt, dann könnte auch die Tiefe der Ordnerstruktur ein Problem sein (max. 3 oder 4 Subdirs tief?) ? Ansonsten habe ich keine Ideen...

Vermutlich ist aber nur deine SD-Karte zickig und du solltest mal andere SD-Karten mit deiner Ultimate testen. Wobei es natürlich auch sein kann, dass deine Ultimate einen Defekt hat. Der Name "Ultimate" war damals recht passend, weil man damals so ziemlich alle Module (bzw. CAR-Images davon) und später auch noch XEX-Dateien laden konnte. Heutzutage passt der Name irgendwie nicht mehr so recht, denn es gibt inzwischen deutlich bessere und preisgünstigere Sachen (die AVG-Cart. kann z.B. deutlich mehr und kostet nur halb soviel wie die Ultimate Cart.)...

Hier noch zwei Links: 1) Tip für einen ca. 50k pull-up resistor, der bei einigen SD-Cards etwas bringen soll (post 6): https://atariage.com/forums/topic/24188 ... nt=3349072
2) Firmware update 1.1 (post 17): https://atariage.com/forums/topic/24188 ... nt=3356125
CharlieChaplin
Night&Day Poster
Night&Day Poster
 
Beiträge: 2283
Registriert: Do 1. Jan 1970, 02:00

Re: ULTIMATE CARD defekt?

Beitragvon Sleepy » Di 30. Jun 2020, 07:24

Ggf. liegt es auch am Typ (nicht Hersteller!) der SD-Karte; es gibt da ja SD (8 MB - 2 GB), SDHC (4-32 GB), SDXC(32 GB - 2 TB) und SDUC (2 - 128 TB).

Imho konnte man z.B. beim sio2sd Anfangs nur Karten des Typs "SD" (max. 2GB) nutzen, was mit späteren Firmwaren auf SDHC erweitert wurde.

Wenn´s für die Ultimate Card quasi keine Updates gab, vlt. gibt es dort ähnliche Einschränkungen auf "reines" SD? Also probiere es mal mit einer alten SD-Karte <=2GB...

Das könnte Deine Beobachtung erklären dass manche Sachen vom ATARI aus sichtbar sind, andere nicht (obwohl auf der SD-Karte gespeichert). Wenn das Ultimate-Card "nur" Karten bis 2 GB verwalten kann, Du aber eine größere Karte hast wo vlt. einige Daten in dem Bereich über 2 GB abgelegt wurden, die das Ultimate Card nicht ansprechen kann... (man korrigiere mich bitte falls die Idee falsch ist!)

Etwas einfach erklärt: Flashspeicher können nicht beliebig oft beschrieben werden. Deshalb werden die Daten nicht immer schön sortiert von Anfang des Speichers zum Ende hin auf das erste freie Stück abgelegt, sondern auf der Karte verteilt, damit diese nicht zu schnell "abnutzt". D.h. wenn Du zwei Datein auf die Karte schreibst, kann es sein dass sie nicht direkt hintereinander liegen, sondern in ganz verschiedenen Speicherbereichen der SD-Karte. Diese Verteilung der Daten auf der SD-Karte regelt die SD-Karte selber.

Sleepy
Benutzeravatar
Sleepy
Night&Day Poster
Night&Day Poster
 
Beiträge: 6969
Registriert: Do 1. Jan 1970, 02:00
Wohnort: Köln

Re: ULTIMATE CARD defekt?

Beitragvon Atausla » Di 30. Jun 2020, 09:05

Hallo,

der Fehler liegt bei mir. Ich bin fest davon ausgegangen,
dass die ULTIMATE CARD auch atr`ś lesen kann...
Die Ordner mit den atr-Files sind eben einfach "leer".

:oops:

Vielen Dank für eure Bemühungen!!!

Andreas
Atausla
Newbie
Newbie
 
Beiträge: 47
Registriert: Fr 2. Okt 2015, 19:28

Re: ULTIMATE CARD defekt?

Beitragvon Sleepy » Di 30. Jun 2020, 09:13

Kein Problem; dafür ist das Forum ja da... :goteam:

Gut dass das Card OK ist.

Sleepy
Benutzeravatar
Sleepy
Night&Day Poster
Night&Day Poster
 
Beiträge: 6969
Registriert: Do 1. Jan 1970, 02:00
Wohnort: Köln


Zurück zu Hardware



Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 3 Gäste