The!Cart

Bild Alles rund um Atari 8bit
Bild All around Atari 8bit

Moderatoren: Sven, Sleepy, Wolfgang, cas, des-or-mad

The!Cart

Beitragvon Moog » Do 4. Jul 2019, 12:07

Hallo

ich hab ein gebrauchtes The!Cart Modul bekommen.
Wenn ich das nun in meinen 800XL reinstecke und anschalte kommt immer nur der Self Test. Die LED leuchtet Orange.Normale Module funktionieren. Mit Option und dem Resetschalter hab ichs auch schon probiert, immer das selbe Ergebnis.

Weis da jemand Rat?

Gruß

Holger
Moog
Newbie
Newbie
 
Beiträge: 44
Registriert: So 1. Jan 2012, 16:25

Re: The!Cart

Beitragvon Sleepy » Do 4. Jul 2019, 12:51

Benutzeravatar
Sleepy
Night&Day Poster
Night&Day Poster
 
Beiträge: 6853
Registriert: Do 1. Jan 1970, 01:00
Wohnort: Köln

Re: The!Cart

Beitragvon Moog » Do 4. Jul 2019, 13:28

Also hab mir das Thecart atr auf Diskette übertragen, und dann mit Optionstaste den Computer gestartet. Dann leuchtet die Orangene LED am Modul und er lädt MyDos von der Diskette. Hab ich da was falsch verstanden in der Anleitung? Mein Englisch ist nicht das beste.Achso mit AspeQct das gleiche.

Gruß
Moog
Newbie
Newbie
 
Beiträge: 44
Registriert: So 1. Jan 2012, 16:25

Re: The!Cart

Beitragvon Sleepy » Do 4. Jul 2019, 18:37

O.K., aus persönlicher Erfahrung kann ich Dir da nichts sagen - ich habe zwar auch ein Modul, da ich z.Z. aber mit dem SIDE bzw. CF 3-Adapter arbeite hab´ ich noch keine Erfahrungswerte...

Da bin ich leider raus.

Sleepy
Benutzeravatar
Sleepy
Night&Day Poster
Night&Day Poster
 
Beiträge: 6853
Registriert: Do 1. Jan 1970, 01:00
Wohnort: Köln

The!Cart

Beitragvon Erhard » Fr 5. Jul 2019, 11:44

Hi,

ich würde nicht zwingend davon ausgehen, daß das The!Cart kaputt ist.

Vielleicht wurde nur versehentlich Schrott in den Flashspeicher des The!Cart geschrieben.

Es gibt für The!Cart Software zum Löschen des gesamten Flashspeichers und es gibt Software, mit der man die Basisfunktion wieder reinschreiben kann. Danach sollte man ein funktionierendes The!Cart mit leerem Menü und ohne Spiele usw haben.

Die Prozedur kann man sicherlich der Anleitung entnehmen und es sollte alles auf wudsn.com zu finden sein.

Wenn das alles nicht funktioniert, einfach noch mal fragen oder das Modul zum nächsten Event mitbringen.

CU, Erhard
Benutzeravatar
Erhard
Star Poster
Star Poster
 
Beiträge: 584
Registriert: Do 1. Jan 1970, 01:00
Wohnort: Radevormwald

Re: The!Cart

Beitragvon Moog » Fr 5. Jul 2019, 14:55

Hallo Erhard

danke für die Info, aber da hab ich gar keinen Durchblick was ich machen muss.
Wie gesagt mein Englisch ist nicht so berauschend. :oops:

Gruß

Holger
Moog
Newbie
Newbie
 
Beiträge: 44
Registriert: So 1. Jan 2012, 16:25

The!Cart

Beitragvon Erhard » Mo 8. Jul 2019, 07:07

Hi,

dann laß es uns mal per Ferndiagnose probieren.

Ich gehe davon aus, daß Dein 800 XL ohne The!Cart richtig funktioniert und daß er beim Einschalten ins BASIC springt, wenn Du weder OPTION drückst noch ein Laufwerk angeschlossen hast.

Versuch 1
-----------
Stecke The!Cart ein und starte den 800 XL mit gedrückter OPTION-Taste und ohne angeschlossene Floppy.

Was kommt?

CU, Erhard
Benutzeravatar
Erhard
Star Poster
Star Poster
 
Beiträge: 584
Registriert: Do 1. Jan 1970, 01:00
Wohnort: Radevormwald

Re: The!Cart

Beitragvon Moog » So 21. Jul 2019, 08:03

Ins Basic springt er. Mit The!Cart wieder in Self Test.

Gruß
Moog
Newbie
Newbie
 
Beiträge: 44
Registriert: So 1. Jan 2012, 16:25

The!Cart

Beitragvon Erhard » So 21. Jul 2019, 11:07

Hi,

versuche bitte nun Folgendes, falls der Rechner mit eingestecktem The!Cart und gedrückter SELECT-Taste ohne angeschlossene Laufwerke ins BASIC startet (ansonsten warte bitte auf neue Anweisungen):

1) Lade Dir diese Software herunter: https://www.horus.com/~hias/thecart/sof ... 170924.zip

2) Starte den Atari mit The!Cart und gedrückten SELECT+OPTION-Tasten von dem THECART.ATR aus dem soeben heruntergeladenem Archiv und starte daraus das Programm FLASH.COM

3) Drücke den Knopf vom The!Cart und danach die RETURN-Taste auf dem Atari.

Wird dann das The!Cart erkannt? Falls ja:

4) lösche das The!Cart vollständig mit "E)" -> dauert sehr lange, 20-30 Minuten

5) Programmiere danach das The!Cart mit "1) Program cartridge"

Danach solltest Du ein funktionierendes The!Cart mit leerem Menü und den eingebauten Tools haben.

Weitere Arbeiten dann mit der aktuellen Version von The!Cart Studio.

Ich erwarte Deine Rückmeldung.

CU, Erhard
Benutzeravatar
Erhard
Star Poster
Star Poster
 
Beiträge: 584
Registriert: Do 1. Jan 1970, 01:00
Wohnort: Radevormwald

Re: The!Cart

Beitragvon Moog » Mo 22. Jul 2019, 16:45

Also mit gedrückter Select Taste geht er auch in den Self Test.

Gruß

Holger
Moog
Newbie
Newbie
 
Beiträge: 44
Registriert: So 1. Jan 2012, 16:25

The!Cart

Beitragvon Erhard » Di 23. Jul 2019, 20:52

Hi,

vorab: bist Du sicher, daß es nicht am Rechner liegen kann? Kontrollier mal den Modulschacht auf verbogene Kontakte oder teste falls möglich das The!Cart in einem anderen Rechner.

Okay, dann würde ich direkt die harte Tour anwenden, aber die ist auf eigene Gefahr. Ich übersetzte hier mal die Beschreibung von der Webseite:

"Wenn alles andere fehlschlägt kann man noch die ausdrücklich nicht empfohlene Methode des Hotpluggens durchführen. Dies kann zu Beschädigungen des Moduls und des Computers führen. Zuerst lädt man ohne eingestecktes The!Cart die Disk mit der Software, Dann wird man aufgefordert, den RESET-Knopf des Moduls zu drücken. An dieser Stelle muß man das Modul vorsichtig und vollständig einstecken. Dann den RESET-Knopf auf dem Modul und danach die RETURN-Taste auf dem Computer drücken. Die Flasher-Software zeigt dann an, ob das The!Cart erkannt wurde und welche Verision davon."

Falls das The!Cart erkannt wurde würde ich es hier vollständig löschen und danach die Grundsoftware draufschreiben. Danach neu testen.

Wenn es dann immer noch nicht funktioniert solltest du die Authoren kontaktieren und das Teil ggf zur Reparatur einschicken.

CU, Erhard
Benutzeravatar
Erhard
Star Poster
Star Poster
 
Beiträge: 584
Registriert: Do 1. Jan 1970, 01:00
Wohnort: Radevormwald

Re: The!Cart

Beitragvon Moog » So 28. Jul 2019, 07:54

Hallo Erhard

vielen Dank für all die Hilfe. Funktioniert jetzt. Hab ein wenig gezögert das auszuprobieren, aber letztendlich hat es funktioniert und es ist nichts kaputt gegangen.

Gruß

Holger
Moog
Newbie
Newbie
 
Beiträge: 44
Registriert: So 1. Jan 2012, 16:25

The!Cart

Beitragvon Erhard » So 28. Jul 2019, 08:09

Hi,

freut mich daß es geklappt hat.

CU, Erhard
Benutzeravatar
Erhard
Star Poster
Star Poster
 
Beiträge: 584
Registriert: Do 1. Jan 1970, 01:00
Wohnort: Radevormwald

Re: The!Cart

Beitragvon Jac » So 28. Jul 2019, 22:28

Hallo,
freut mich sehr, dass es geklappt hat. Bei solchen Dingen ist es auch immer gut, mal auf einem ABBUC Treffen vorbeizuschauen. Da hat immer jemand seltenere nützliche Hardware wie den Freezer dabei. Damit fixt/analysiert man vieles auch "weniger blutig" :-)

Viele Grüße, Peter.
Jac
Star Poster
Star Poster
 
Beiträge: 499
Registriert: Do 1. Jan 1970, 01:00
Wohnort: 66822 Lebach

The!Cart

Beitragvon Erhard » Mo 29. Jul 2019, 10:13

Hi Jac,

ich geh mal davon aus, daß das Flash im The!Cart nicht steckbar ist.

Sonst hätte er mir das Teil ja schicken können, dann hätte ich es notfalls den Chip mit dem GALEP gelöscht.

So per Ferndiagnose sehe ich nicht viel mehr Optionen als in diesem Thema abgearbeitet, oder?

CU, Erhard
Benutzeravatar
Erhard
Star Poster
Star Poster
 
Beiträge: 584
Registriert: Do 1. Jan 1970, 01:00
Wohnort: Radevormwald

Re: The!Cart

Beitragvon Jac » Mo 29. Jul 2019, 13:18

Hallo Erhard,

ja, wenn man sonst nix hat (Freezer, Angepasstes OS, ...) ist hier alles bestmöglich abgehandelt.
Und ja, der Flash ist nicht gesockelt und via JTAG ist nur der CPLD erreichbar.

Viele Grüße, Peter.
Jac
Star Poster
Star Poster
 
Beiträge: 499
Registriert: Do 1. Jan 1970, 01:00
Wohnort: 66822 Lebach

The!Cart

Beitragvon Erhard » Mo 29. Jul 2019, 14:29

Hapüh !

:-)
Benutzeravatar
Erhard
Star Poster
Star Poster
 
Beiträge: 584
Registriert: Do 1. Jan 1970, 01:00
Wohnort: Radevormwald


Zurück zu Hardware



Wer ist online?

Mitglieder in diesem Forum: Google [Bot] und 4 Gäste