WUDSN IDE: Das 6502 Assembler Plugin für Eclipse

Bild Alles zum Thema Programmierung
Bild All around programming

Moderatoren: Sven, Sleepy, Wolfgang, cas, des-or-mad

WUDSN IDE: Das 6502 Assembler Plugin für Eclipse

Beitragvon Jac » Mo 8. Jun 2009, 22:47

Hallo zusammen,

Endlich habe ich es geschafft und die erste Version von "WUDSN IDE" - dem freien integrierten Atari 8-bit Assembler Plugin für Eclipse ist auf http://www.wudsn.com verfügbar.

Ich habe sie komplett neu geschrieben (ja, die Festplatte ist tot...) und sie umfasst nun folgende Funktionen:
  • Voll integrierter Assembler Editor mit Syntaxhervorhebung, inplace Compilierung und Fehlernavigation
  • Strukturansicht und Auf/Zuklappen für Macros und Abschnitte
  • Content Assist und Code Completion
  • Hyperlink Navigation zu Source-Includes und Binär-Includes
  • Erzeugung von Label Definitionsdateien für Emulatoren


Im Abschnitt "Features" findet ihr die vollständige Liste, Tonnen von Screenshots und die Liste der Bugs und geplanten Funktionen.
Im Abschnitt "Installation" findet ihr die Schritt-für-Schritt Anleitungen zur Installation und Konfiguration von Eclipse, dem Plugin und den zusätzlichen Komponenten.

Die Website ist komplett in English, aber das sollte für so die Zielgruppen ja kein Problem sein. :lol:

Wenn ihr Feedback habt, schickt mir einfach eine E-Mail (Adresse siehe Webseite) oder verwendet diesen Thread.

Viele Grüße, Peter.

Editor:
Bild

Voreinstellungen:
Bild
Jac
Multi Poster
Multi Poster
 
Beiträge: 385
Registriert: Do 1. Jan 1970, 01:00
Wohnort: 66822 Lebach

Beitragvon cas » Di 9. Jun 2009, 07:18

Wow, Peter, das sieht ja Spitze aus. WUDSN IDE werde ich sicher ausprobieren und hier von meinen Erfahrungen berichten!

Vielen Dank schon mal für dieses neue Spielzeug/Werkzeug!

Carsten
cas
Night&Day Poster
Night&Day Poster
 
Beiträge: 1973
Registriert: Do 1. Jan 1970, 01:00
Wohnort: Neuenkirchen (Rheine)

Beitragvon mp-one » Do 11. Jun 2009, 10:22

Hallo Peter!

Klasse, was Du da geleistet hast! Ich hatte Eclipse sowieso installiert und habe Dein Plugin gestern Abend gleich mal mit einem Mini-Programm (*=$600 lda #32 sta 712) getestet. Hat super geklappt. Auch Dein mitgeliefertes sample läuft problemlos per Compile & Run auf dem Atari800-Win. Das sind für mich ganz neue Aussichten. Ich wollte gerade von ATMAS auf BiboAssembler und/oder einen CrossAssembler wechseln, da kommt Dein Plugin 100% richtig :)!

Haben die erzeugten XEX-Files eigentlich das (Standard-) Format [$FF $FF StartAdr EndAdr Programm]? Ich würde einige kleine Assemblerroutinen nämlich gerne in BASIC-Strings wandeln und da habe ich ein Programm, das genau dieses Format ausliest.

[edit] Hab gerade mal mit dem Hex-Editor geschaut, es scheint das Format zu sein. [/edit]

Beste Grüße und vielen Dank für das geniale Tool!

Michael
Benutzeravatar
mp-one
Star Poster
Star Poster
 
Beiträge: 744
Registriert: Do 1. Jan 1970, 01:00

Super Arbeit!!!

Beitragvon carsten_92000 » Sa 4. Jul 2009, 23:39

Hallo Peter,
Du hast tolle Arbeit geleistet. Auch die Installationsanleitung war super verständlich. Habe schon in diversen Atari Foren nach einem Assembler für den XL gesucht (vornehmlich den Atmas II), aber dein Eclipse PlugIn ist der Hammer! Wie lange hast Du daran gearbeitet?
Beste Grüsse aus Berlin

Carsten



:danke2 :danke2 :danke2
Benutzeravatar
carsten_92000
Newbie
Newbie
 
Beiträge: 1
Registriert: Do 1. Jan 1970, 01:00
Wohnort: Berlin

Beitragvon Cash » So 5. Jul 2009, 09:50

Hi,
ich habe probleme beim einstellen der editoren preferences. Ich habe ein Mac OSX 10.4 PPC. Erstens dauert es furchtbar lange wenn ich die .app einstellen will vom Atari800 emulator und auch von Atasm die execute file und zweitens sagt das programm mir das "value must be an existing file" sein ?! Kann mir da vielleicht jemand weiterhelfen?
gruß
cash

Atari8bit-Yuppie
Benutzeravatar
Cash
Star Poster
Star Poster
 
Beiträge: 768
Registriert: Do 1. Jan 1970, 01:00
Wohnort: Bielefeld/NRW

Beitragvon atarixle » Di 7. Jul 2009, 18:02

Also irgendwie scheint es nicht möglich zu sein, den Atari800MacX als Emulator anzugeben.

Jedesmal, wenn ich das machen will, kann ich die Einstellungen nicht übernehmen ("Apply" und " OK " werden ausgegraut).

PS (einen Tag später): ich hab OSX 10.4 in der Intel-Version

Man muss dazu sagen, dass Mac OS X 10.4 nur mit Java 1.5 daherkommt, vielleicht ist da ein Bug drin, der nur unter Java 1.5 auftritt.
Zuletzt geändert von atarixle am Mi 8. Jul 2009, 15:04, insgesamt 1-mal geändert.
am 27. Mai 2017 ABBUC in Berlin: http://www.atarixle.de/AIB
vom 17. bis 20. August 2017 Fujiama: http://abbuc.de/fujiama
RespeQt für Linux: http://abbuc.de/~atarixle/download/#respeqt

Meine Seite:
http://www.atarixle.de
atarixle
Super Poster
Super Poster
 
Beiträge: 955
Registriert: Do 1. Jan 1970, 01:00
Wohnort: Guben

Beitragvon Cash » Di 7. Jul 2009, 23:01

atarixle hat geschrieben:Also irgendwie scheint es nicht möglich zu sein, den Atari800MacX als Emulator anzugeben.

Jedesmal, wenn ich das machen will, kann ich die Einstellungen nicht übernehmen ("Apply" und " OK " werden ausgegraut).


Bei mir hab ich das gleiche Problem :roll:
gruß
cash

Atari8bit-Yuppie
Benutzeravatar
Cash
Star Poster
Star Poster
 
Beiträge: 768
Registriert: Do 1. Jan 1970, 01:00
Wohnort: Bielefeld/NRW

Beitragvon Jac » So 12. Jul 2009, 03:14

2009-07-12 IDE update 1.2.0 released

Check out the details on "http://www.wudsn.com"

After a major rework a lot of new features were added and the first usable version of the MADS integration is available now. Now "only" content outline and label file creation are not available yet. I know may people are waiting for the content outline, but I first had to get the syntax for all definitions of pseudo opcodes and directives straight and had to extend the parsing to block comments. Otherwise parsing for a content outline is simply not possible. And comparing the 61 definitions in ATASM (described in an English manual) to the 168 (!) definitions in MADS (described in a Polish manual) you may understand what kept me busy in the past weeks. And without the great support from Tebe for the technical details it would surely not have been possible! Also my wife did a great job in translating the relevant sections of the MADS manual for me, so thanks for that!

Unfortunately the starting the emulator automatically on MacOS X does not work yet. At least if have Mac OS X emulation up and running now for my tests and found out that the problem is passing parameters to the "open" command in addition to the binary file name. Maybe somebody here knows how to do that. Or maybe even Atari800MacOSX does not support any parameter apart from the binary file name...

04:08 AM See you tomorrow ;-)

JAC!

PS: Das o.g. Problem mit der Voreinstellungen ist gelöst (siehe Release News), aber ich kriege nicht heraus, wie ich bei "open -a Atari...app -run test.xex" das "-run" übergeben bekomme. Vieleicht habt ihr ja eine Idee (ist heute das erst Mal, dass ich Atar800MacX sehe...
Jac
Multi Poster
Multi Poster
 
Beiträge: 385
Registriert: Do 1. Jan 1970, 01:00
Wohnort: 66822 Lebach

Beitragvon Volkert » So 12. Jul 2009, 09:28

Jac hat geschrieben:2009-07-12 IDE update 1.2.0 released

PS: Das o.g. Problem mit der Voreinstellungen ist gelöst (siehe Release News), aber ich kriege nicht heraus, wie ich bei "open -a Atari...app -run test.xex" das "-run" übergeben bekomme. Vieleicht habt ihr ja eine Idee (ist heute das erst Mal, dass ich Atar800MacX sehe...


Probiere mal das:
open TEST.XEX -a Atari800MacX

So kann ich zumindest XEX, ATR etc. direkt starten.

Gruesse,
Volkert
Volkert
Junior Poster
Junior Poster
 
Beiträge: 140
Registriert: Do 1. Jan 1970, 01:00
Wohnort: Laufenburg

Beitragvon skriegel » So 12. Jul 2009, 11:14

Jac hat geschrieben:PS: Das o.g. Problem mit der Voreinstellungen ist gelöst (siehe Release News),


Prima.

aber ich kriege nicht heraus, wie ich bei "open -a Atari...app -run test.xex" das "-run" übergeben bekomme. Vieleicht habt ihr ja eine Idee (ist heute das erst Mal, dass ich Atar800MacX sehe...


Genau so wie Volkert es beschreibt, funktioniert es auch bei mir.

Aber auch so wie es jetzt ist, kann ich schon damit arbeiten und endlich mal Assembler lernen. :-)
If you read this for the second time, you are quite bored.
Benutzeravatar
skriegel
Night&Day Poster
Night&Day Poster
 
Beiträge: 2021
Registriert: Do 1. Jan 1970, 01:00
Wohnort: Somewhere over the rainbow

Beitragvon Jac » So 26. Jul 2009, 02:53

2009-07-26 IDE update 1.3.2 released

Willkommen zum "M&M" Release mit Unterstützung für Mac OS X und MADS Strukturanzeige. Über das Menü "Hilfe/Software" könnt ihr von Version 1.2.0 auf Version 1.3.2. Bitte beachtet, dass ihr zurvor die Version 1.2.0 (oder niedriger) unbedingt deinstallieren müsst, da die sehr viel an der Struktur der Pakete und der Voreinstellungen geändert hat. Nach der Installation bitte die Voreinstellungen prüfen und ggfs. anpassen.

Unter http://www.wudsn.com gibt es alle Details über die Erweiterungen und Korrekturen.


Viele Grüße, Peter .. der scheinbar letzte Atari Fan der keinen echten Mac hat ;-)

Bild
Jac
Multi Poster
Multi Poster
 
Beiträge: 385
Registriert: Do 1. Jan 1970, 01:00
Wohnort: 66822 Lebach

Beitragvon skriegel » Di 28. Jul 2009, 21:50

Ups. Unbedingt erst deinstallieren habe ich natürlich vergessen. Läuft trotzdem... Aber gut, dann nochmal mit deinstallieren. :-)
If you read this for the second time, you are quite bored.
Benutzeravatar
skriegel
Night&Day Poster
Night&Day Poster
 
Beiträge: 2021
Registriert: Do 1. Jan 1970, 01:00
Wohnort: Somewhere over the rainbow

Forthcoming Version 1.4.0

Beitragvon Jac » Fr 11. Sep 2009, 00:13

My summer vacation is about to end and so finally there is some progress with the new WUDSN IDE features. There was a lot of "meta-coding" to be done to put myself in a position to create an interactive application like the graphics converter. I plan to release the ASM updates together with an alpha version of the GFX plugin this weekend. You can read the details on http://www.wudsn.com.
ide-graphics-editor-1.png
ide-graphics-editor-1.png (13.29 KiB) 11227-mal betrachtet
Jac
Multi Poster
Multi Poster
 
Beiträge: 385
Registriert: Do 1. Jan 1970, 01:00
Wohnort: 66822 Lebach

Re: WUDSN IDE: Das 6502 Assembler Plugin für Eclipse

Beitragvon Jac » Fr 9. Okt 2009, 20:47

WUDSN IDE 1.4.0++ / Site update

Hi there,

I finally managed to update the new and the features section on http://http://www.wudsn.com with the details of the version 1.4.0 and also even the details of the new version 1.4.2 which I'm going to release (hopefully ;-)) tomorrow.

Have fun, Peter.
Jac
Multi Poster
Multi Poster
 
Beiträge: 385
Registriert: Do 1. Jan 1970, 01:00
Wohnort: 66822 Lebach

Re: WUDSN IDE: Das 6502 Assembler Plugin für Eclipse

Beitragvon Bernd » Do 5. Aug 2010, 22:06

Man glaubt es kaum......meinen M65 Assembler Text ausgedruckt, die Zeilennummern entfernt und mit dem WUDSN IDE assembliert.
Nur einen Fehler bekommen, korregiert...und dann das Ergebnis....Invertierter Text wird im M65-Ausdruck unter Windows zu so etwas: .BYTE "ÁÔÔÅÎÔÉÏκ",EOL
und trotdem KORREKT als "ATTENTION" invertiert übersetzt. Zeigt die Klasse des Programms :notworthy:

So einfach hätte ich es mir nie vorgestellt. Von nun an nur noch WUDSN IDE...alleine beim Assemblieren spare ich mir viel Zeit.


Dank an Peter dem Entwickler,
Bernd
Bernd
Night&Day Poster
Night&Day Poster
 
Beiträge: 2797
Registriert: Do 1. Jan 1970, 01:00

Re: WUDSN IDE: Das 6502 Assembler Plugin für Eclipse

Beitragvon atarixle » Sa 7. Aug 2010, 10:26

Ich hab das Plug-In auch grad installiert. Klappt problemlos. Leider habe ich kein Mac OS X Tiger mehr, sondern SnowLeopard, so dass ich für die Probleme, die unter Tiger aufgetreten sind, kein Feedback mehr geben kann.
am 27. Mai 2017 ABBUC in Berlin: http://www.atarixle.de/AIB
vom 17. bis 20. August 2017 Fujiama: http://abbuc.de/fujiama
RespeQt für Linux: http://abbuc.de/~atarixle/download/#respeqt

Meine Seite:
http://www.atarixle.de
atarixle
Super Poster
Super Poster
 
Beiträge: 955
Registriert: Do 1. Jan 1970, 01:00
Wohnort: Guben

Re: WUDSN IDE: Das 6502 Assembler Plugin für Eclipse

Beitragvon Jac » So 8. Aug 2010, 07:25

@Bernd: Danke für die Blumen! Der Teil für den Compiler gebührt natürlich Mark Schmelzenbach, dem Autor von ATASM.

@Mirko: Habe inzwischen eine laufende Tiger Installation und seit 1.4.0 geht dort auch alles.

Ich freue mich echt, dass wir uns auf der Fujiama getroffen habe und dass die IDE euch gefällt.
Jac
Multi Poster
Multi Poster
 
Beiträge: 385
Registriert: Do 1. Jan 1970, 01:00
Wohnort: 66822 Lebach

Re: WUDSN IDE: Das 6502 Assembler Plugin für Eclipse

Beitragvon Bernd » So 8. Aug 2010, 22:52

Jac hat geschrieben:@Bernd: Der Teil für den Compiler gebührt natürlich Mark Schmelzenbach, dem Autor von ATASM.

Hallo Peter,
ich möchte Mark Schmelzenbach Leistung nicht schmälern. Ohne deine Oberfläche müsste man den Quelltext mit einem normalen Editor erstellen und anschließend per Dosen Fenster die Optionsbits und den Quelltext dem Assembler übergeben. Dies war bei mir bislang der Grund, sich mit dem ATASM nicht zu beschäftigen. Was mir vor allem gefällt, ein Klick auf den Atari Rechner und alles läuft automatisch ab. Der Quelltext wird gespeichert, anschließend erfolgt der Assemblerdurchlauf und zum Schluss startet das Programm im Atari800Win PLus 4.0 Emulator. Was ich vorher am Ablauf an Zeit gelassen habe, ist unglaublich. Eine benutzerfreundliche Oberfläche ist und bleibt das "A" und "O" eine Programmes und da hast du eine erstklassige Arbeit abgeliefert.

Nochmals vielen Dank für die Software und das Einrichten,
Bernd
Bernd
Night&Day Poster
Night&Day Poster
 
Beiträge: 2797
Registriert: Do 1. Jan 1970, 01:00

Re: WUDSN IDE: Das 6502 Assembler Plugin für Eclipse

Beitragvon atarixle » Di 10. Aug 2010, 00:16

Jac hat geschrieben:...
Ich freue mich echt, dass wir uns auf der Fujiama getroffen habe und dass die IDE euch gefällt.


Nachdem ich gesehen hab, wie du damit gearbeitet hast, musste ich das unbedingt nochmal probieren ...

ich hab's auch gleich mal auf allen Plattformen installiert, auf denen ich Eclipse laufen habe.

Da fällt mir ein, die Installationsanleitung solltest du mal aktualisieren. Einige Menüpunkte wurden in den neueren Eclipe-Versionen zum Besseren umbenannt: man muss nicht mehr auf Help > Softwareupdates klicken, sondern Help > Install New Software. Und in der Mac-Version von Eclipse ist das Preferences-Fenster im Menü nicht unter Window, sondern unter Eclipse zu finden (das solltest du vorsichtshalber erwähnen, ich hab erst eine Weile suchen müssen :D ).

Die Einstellung für den Emulator Atari800Win kann auch unter Linux mit Atari800 genutzt werden, vielleicht solltest du das Win in Klammern setzen, damit man sieht, dass auch der Atari800 damit funktioniert.

Kleiner Tipp für Linux x86_64 User: der ATASM funktioniert hier nicht (jedenfalls bei mir nicht ... kA, wieso, es heißt immer file not found ... ich kann den auch nicht von der Konsole aus starten ... Executable-Bit ist gesetzt). An dieser Stelle kann getrost atasm.exe (die Windows Version) verwendet werden - vorausgesetzt, WINE ist installiert und das Executable-Bit ist gesetzt (Eigenschaften > als Programm ausführen bzw. chmod +x atasm.exe). Das Funktioniert bestens.
am 27. Mai 2017 ABBUC in Berlin: http://www.atarixle.de/AIB
vom 17. bis 20. August 2017 Fujiama: http://abbuc.de/fujiama
RespeQt für Linux: http://abbuc.de/~atarixle/download/#respeqt

Meine Seite:
http://www.atarixle.de
atarixle
Super Poster
Super Poster
 
Beiträge: 955
Registriert: Do 1. Jan 1970, 01:00
Wohnort: Guben

Re: WUDSN IDE: Das 6502 Assembler Plugin für Eclipse

Beitragvon cas » Di 10. Aug 2010, 08:53

atarixle hat geschrieben:Kleiner Tipp für Linux x86_64 User: der ATASM funktioniert hier nicht (jedenfalls bei mir nicht ... kA, wieso, es heißt immer file not found ... ich kann den auch nicht von der Konsole aus starten ... Executable-Bit ist gesetzt). An dieser Stelle kann getrost atasm.exe (die Windows Version) verwendet werden - vorausgesetzt, WINE ist installiert und das Executable-Bit ist gesetzt (Eigenschaften > als Programm ausführen bzw. chmod +x atasm.exe). Das Funktioniert bestens.



Hallo Mirko,

ich habe gerade ATASM 1.07d unter Fedora Linux x86_64 compiliert, es funktioniert ohne probleme. Es kann sein das ein für x86 (32bit) binary von ATASM nicht funktioniert, wenn Du die 32bit libraries nicht installiert hat (das erklärt das "file not found", es wird eine oder mehr Programmbibliotheken nicht gefunden, kannst Du mit "ldd atasm" testen).

Code: Alles auswählen
[root@fedora src]# ldd atasm
   linux-vdso.so.1 =>  (0x00007fff4a2c0000)
   libz.so.1 => /lib64/libz.so.1 (0x0000003d8d800000)
   libc.so.6 => /lib64/libc.so.6 (0x0000003d8c800000)
   /lib64/ld-linux-x86-64.so.2 (0x0000003d8c000000)


Um ATASM auf neueren Maschinen zu kompilieren, muss im "Makefile" der CFLAGS (Einstellungen für den Kompiler) der Parameter "march" (Machine Architecture, gibt die Prozessorarchitektur an) von "pentiumpro" (alter Pentium Pro) auf "native" (findet den aktuellen Prozessor selber heraus) geändert werden.

Code: Alles auswählen
CFLAGS  = -Wall $(USEZ) $(DOS) $(UNIX) -O3 -fomit-frame-pointer -march=native


Für ATASM WINE zu benutzen ist richtig ineffektiv, da für jeden Assembliervorgang ein ganzes Windows gestartet werden muss ;)

Ich habe ATASM 1.07d für Linux x86_64 als tar-ball angehangen.

Auspacken mit
Code: Alles auswählen
cd /; tar xvfz atasm107d-x86_64.tgz
Dateianhänge
atasm107d-x86_64.tgz
(278.49 KiB) 319-mal heruntergeladen
cas
Night&Day Poster
Night&Day Poster
 
Beiträge: 1973
Registriert: Do 1. Jan 1970, 01:00
Wohnort: Neuenkirchen (Rheine)

Nächste

Zurück zu Programmierung



Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast